操作系统支持

表 1 列出了英特尔® Quartus® 专业版软件、英特尔 Quartus Prime 标准版软件、英特尔 Quartus Prime 精简版软件、ModelSim*-英特尔 FPGA Edition 软件、ModelSim-英特尔 FPGA 入门版软件、Nios® II 嵌入式设计套件 (EDS)、面向英特尔 FPGA 的 DSP Builder和面向 OpenCL™ 软件技术的英特尔 FPGA SDK 支持的操作系统 (OS)。

表 1:面向英特尔® FPGA 完整设计套件版本 21.1 的操作系统支持(1)

软件Windows* 10Windows Server* 2012 EnterpriseWindows Server* 2016 EnterpriseWindows Server* 2019 EnterpriseRed Hat* Enterprise Linux* 7Red Hat* Enterprise Linux* 8CentOS 7.5 CentOS 8.0SUSE* SLE 12SUSE* SLE 15Ubuntu*
16.04 
LTS
Ubuntu* 18.04 LTS

Ubuntu* 20

LTS

英特尔® Quartus® Prime 专业版         ✓(5)(5)    ✓
英特尔® Quartus Prime 标准版        ✓(5)(5)   ✓
英特尔 Quartus Prime 精简版    ✓(5)(5)     ✓
英特尔® HLS 编译器专业版
 ---    ----
ModelSim*-英特尔® FPGA 版 
(专业版与标准版)
(2)-- -(2)(2)--(2)
   ✓(2)---
ModelSim-英特尔 FPGA 入门版(专业版与标准版)(2)---(2)(2)--(2)
    ✓(2) -      --
Nios® II 嵌入式设计套件 (EDS)(专业版与标准版)(4)      ------- -- --
面向英特尔® FPGA 的 DSP Builder(专业版)
    ✓     ✓
英特尔 Quartus Prime Stand-Alone Programmer(专业版与标准版)    ✓       ✓
面向 OpenCL™ 的英特尔® FPGA SDK(专业版) 
         ---
    -      ✓
-
英特尔® 高级链路分析器 
(专业版与标准版)
        ✓--- ---- - -

注意:

  1. 从英特尔® Quartus® Prime 软件 14.0 版开始,除非另有说明,否则英特尔® FPGA 软件仅支持表 1 中列出的 64 位操作系统。在 Linux* 64 位平台上运行该软件需要 32 位库文件。
  2. 只有英特尔 Quartus Prime 标准版软件 18.1 和更低版本支持 32 位独立编程器。
  3. 从英特尔 Quartus Prime 标准版软件版本 18.0 版本开始不再支持 Red Hat 5。
  4. 从英特尔 Quartus Prime 专业版软件版本 19.2 和英特尔 Quartus Prime 标准版软件版本 19.1 中的 Nios II EDS 开始,Nios II EDS 的 Windows 版本中的 Cygwin 组件已不再使用,由 WSL 代替。有关安装说明,请参阅 Nios II 软件开发人员手册中 Windows 部分的“安装 Windows Subsystem for Linux (WSL)”部分。对于安装了 McAfee* Endpoint Security 的计算机,最低要求是 Windows 10 版本 1809(操作系统内部版本 17763)。如果您将网络驱动器用于 Nios II EDS,最低要求为 Windows 10 版本 1903(操作系统内部版本 18362)。
  5. Windows 7 不再支持英特尔 Quartus Prime 标准版与专业版,取而代之的是 Window 10。Windows 用户需要下载和安装面向 Windows 10 的 Windows Subsystem for Linux (WSL)。  
  6. 面向英特尔 FPGA 的 DSP Builder 依赖于 Matlab(DSPB 实际上是 Matlab 的插件),因此面向英特尔 FPGA 的 DSP Builder 支持的真正的操作系统十分有限,请用户参考 MathWorks* 操作系统支持网页。
  7. 从英特尔 Quartus Prime 软件 20.3 版本开始,不再提供英特尔 SoC FPGA 嵌入式开发套件 (SoC EDS)。构成 SoC EDS 的组件现在只能通过 GitHub 获得。有关详细信息,请访问英特尔 FPGA 下载中心。 

有关软件系统要求的更多信息,请参阅以下页面:

   > 英特尔 Quartus Prime 标准版软件页面

如欲了解针对各种英特尔 FPGA 架构的设计所提出的系统内存要求,请参考:

如欲获取关于 ACDS 的详细信息,请参阅表 2 中的 readme.txt 文件。

表 2 列出了新版和旧版英特尔 Quartus 软件以及相应的 ModelSim-英特尔 FPGA 软件版本的版本说明和 readme.txt 文件。

表 2:版本说明与 readme.txt 文件

英特尔® Quartus® Prime 软件版本ModelSim*-英特尔® FPGA 软件版本

英特尔 Quartus Prime 设计软件 v21.1

ModelSim-英特尔 FPGA 2021.1(兼容英特尔 Quartus Prime 专业版软件)

英特尔 Quartus Prime 设计软件 v20.4

ModelSim-英特尔 FPGA 2020.3(兼容英特尔 Quartus Prime 专业版软件)

英特尔 Quartus Prime 设计软件 v20.3

ModelSim-英特尔 FPGA 2020.3 (兼容英特尔® Quartus® Prime 专业版软件)

英特尔 Quartus Prime 设计软件 v20.2

ModelSim-英特尔 FPGA 2019.2 (兼容英特尔® Quartus® Prime 专业版软件)

英特尔 Quartus Prime 设计软件 v20.1

ModelSim-英特尔 FPGA 2019.2(兼容英特尔 Quartus Prime 专业版软件)

ModelSim-英特尔 FPGA 2020.1(兼容英特尔 Quartus Prime 标准版软件)

英特尔 Quartus Prime 设计软件 v19.4

ModelSim-英特尔 FPGA 2019.2(兼容英特尔 Quartus Prime 专业版软件)

英特尔 Quartus Prime 设计软件 v19.3

 

 

ModelSim-英特尔 FPGA 10.6d(兼容英特尔 Quartus Prime 专业版软件)

英特尔 Quartus Prime 设计软件 v19.2

ModelSim-英特尔 FPGA 10.6d(兼容英特尔 Quartus Prime 专业版软件)

英特尔 Quartus Prime 设计软件 v19.1

ModelSim-英特尔 FPGA 10.6d(兼容英特尔 Quartus Prime 专业版软件)

ModelSim-英特尔 FPGA Edition 版本 10.5b(兼容英特尔 Quartus Prime 专业版软件)


英特尔 Quartus Prime 设计软件 v18.1

ModelSim-英特尔 FPGA 10.6d(兼容英特尔 Quartus Prime 专业版软件)

ModelSim-英特尔 FPGA 10.5b(兼容英特尔 Quartus Prime 标准版软件)

英特尔 Quartus Prime 设计软件 v18.0

ModelSim-英特尔 FPGA 10.6c(兼容英特尔 Quartus Prime 专业版软件)

ModelSim-英特尔 FPGA 10.5b(兼容英特尔 Quartus Prime 标准版软件)

英特尔 Quartus Prime 设计软件 v17.1

ModelSim-英特尔 FPGA 10.5c(兼容英特尔 Quartus Prime 专业版软件)

ModelSim-英特尔 FPGA 10.5b(兼容英特尔 Quartus Prime 标准版软件)

英特尔 Quartus Prime 设计软件 v17.0

ModelSim- 英特尔 FPGA 10.5c

英特尔 Quartus Prime 设计软件 v16.1

ModelSim- 英特尔 FPGA 10.5b

英特尔 Quartus Prime 设计软件 v16.0

ModelSim- 英特尔 FPGA 10.4d

英特尔 Quartus Prime 设计软件 v15.1

ModelSim- 英特尔 FPGA 10.4b

OpenCL 和 OpenCL 标识是苹果公司的商标,需获得 Khronos 的许可方能使用。

Nios 是英特尔公司或其子公司在美国和/或其他国家的商标。 

英特尔和 Quartus 是英特尔公司或其子公司在美国和/或其他国家的商标。