Intel® Integrated Performance Primitives System Requirements for Intel® oneAPI Base Toolkit

ID 标签 763946
已更新 6/14/2024
版本 Latest
公共

author-image

作者

Introduction

This document provides the information on the system requirements for:

  • Intel® Integrated Performance Primitives (Intel® IPP)
  • Intel® Integrated Performance Primitives Cryptography (Intel® IPP Cryptography)

Supported Hardware Platforms

Depending on the software distribution that you received Intel® IPP with, the Intel® IPP supports the following processor types:

  • Intel® Core™ Processor Family  
  • Intel® Core™ Ultra Processors 
  • Intel® Xeon® Processor Family  
  • Intel Atom® Processors 

Supported Operating Systems

Windows*

  • Windows* 10, 11 
  • Windows Server* 2019, 2022 
  • Use of Intel® Advanced Vector Extensions (Intel® AVX) and Intel® Advanced Vector Extensions 2 (Intel® AVX2) instructions require Microsoft Windows* 10 and Windows Server* 2016, or a higher version. 
  • Use of Intel® Advanced Vector Extensions 512 (Intel® AVX-512) instructions require Microsoft Windows Server* 2016, or a higher version. 

Linux*

  • Red Hat Enterprise Linux (RHEL)* 8, 9  
  • SUSE Linux Enterprise Server* (SLES) 15 SP3, SP4, SP5 
  • Ubuntu* 20.04 LTS, 22.04 LTS 
  • Rocky Linux 9 
  • Fedora* 37, 38, 39 
  • Use of Intel® Advanced Vector Extensions (Intel® AVX) and Intel® Advanced Vector Extensions 2 (Intel® AVX2) instructions require Linux kernels from 2.6.30 and later. 
  • Use of Intel® Advanced Vector Extensions 512 (Intel® AVX-512) instructions require Linux kernels from 3.15 and later. 

Note: Intel® IPP is expected to work on many more Linux distributions as well. Let us know (Forum) if you have trouble with the distribution you use. 

Supported Compilers

Linux*

  • Intel® oneAPI DPC++/C++ Compiler 2023.1 for Linux* OS and later 
  • GNU Compilers 8.x and higher 
  • Glibc version 2.28 or higher 

Windows*

  • Intel® DPC++/C++ Compiler 2023.1 and later 
  • Microsoft Visual Studio* 2019  
  • Microsoft Visual Studio* 2022  

Deprecation Notices 

The following Operating System support is now deprecated and will be discontinued with the oneAPI 2025.0 release in Fall 2024. 

  • SUSE Linux Enterprise Server (SLES) version 15 SP3 
  • Ubuntu Linux version 20.04 
  • Debian Linux version 11 
  • Amazon Linux version 2022 
  • macOS Deprecation 
  • Intel® Integrated Performance Primitives (Intel® IPP) for macOS is deprecated in release 2021.10 and will be discontinued as of Intel IPP release version 2021.11 and later releases. 
  • Intel® Integrated Performance Primitives Cryptography (Intel® IPP Cryptography) for macOS is deprecated in release 2021.9 and will be discontinued as of Intel® IPP Cryptography version 2021.10 and later releases. 

Notices and Disclaimers

Intel technologies may require enabled hardware, software or service activation.

No product or component can be absolutely secure.

Your costs and results may vary.

© Intel Corporation. Intel, the Intel logo, and other Intel marks are trademarks of Intel Corporation or its subsidiaries. Other names and brands may be claimed as the property of others.

No license (express or implied, by estoppel or otherwise) to any intellectual property rights is granted by this document.

The products described may contain design defects or errors known as errata which may cause the product to deviate from published specifications. Current characterized errata are available on request.

Intel disclaims all express and implied warranties, including without limitation, the implied warranties of merchantability, fitness for a particular purpose, and non-infringement, as well as any warranty arising from course of performance, course of dealing, or usage in trade.