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This chapter describes using the Transceiver Toolkit to optimize high-speed serial links in your board design.
The Transceiver Toolkit provides real-time control, monitoring, and debugging of the transceiver links
running on your board.

You can control the transmitter or receiver channels to optimize transceiver settings and hardware features.
The toolkit tests bit-error rate (BER) while running multiple links at the target data rate. You can also run
auto sweep tests to identify the best PMA settings for each link. An “EyeQ “graph displays the receiver
horizontal and vertical eye margin during testing. The toolkit supports testing of multiple devices across
one or more boards simultaneously.

Figure 11-1: Transceiver Toolkit GUI
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Quick Start

Get started quickly by downloading Transceiver Toolkit design examples from the On-Chip Debugging
Design Exampleswebsite. For an online demonstration of how to use the Transceiver Toolkit to run a high-
speed link test with one of the design examples, refer to theTransceiver ToolkitOnlineDemo on the Altera
website.
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Transceiver Debugging Overview
Testing transceiver links involves configuring your system for debug, and then running various link tests.
The following table details the steps in this flow.

Table 11-1: Transceiver Link Debugging Flow

Flow Description

1. Use one of the following methods to define a system that includes necessary transceiver
debugging components:

• Click Tools > Qsys and modify Altera design examples for use with your design.
• Click Tools > MegaWizard Plug-In Manager to define and integrate debugging

components into your own design.

2. Click Assignments > Pin Planner to assign device I/O pins to match your device and
board.

3. Click Processing > Start Compilation to compile your design.
4. Connect your target device to Altera programming hardware.
5. Click Tools > Programmer to program your target device.

System
Configuration
Steps

1. Click File > Load Design, and select the SRAM Object File (.sof) generated for your
transceiver design.

2. (Optional) Create any additional links between transmitter channel and receiver.
3. Run any of the following tests:

• Run BER with various combinations of PMA settings.
• Run PRBS Signal eye tests
• Run custom traffic tests
• Run link optimization tests
• Directly control PMA analog settings to experiment with settings while the link is

running

LinkDebugging
Steps

Using the Transceiver Toolkit GUI
The Transceiver Toolkit GUI helps you to easily visualize and debug transceiver links in your design. To
launch the GUI, click Tools > System Console > Transceiver Toolkit.

Related Information
Toolkit GUI Setting Reference on page 11-21

Controlling Transceiver Channels
You can directly control and monitor transmitters, receivers, and links running on the board in real time.
You can transmit a data pattern across the transceiver link, and then report the signal quality of the received
data in terms of bit error rate or eye margin with EyeQ. ClickControl Transmitter (Transmitter Channels
tab),ControlReceiver (ReceiverChannels tab), orControl Link (TransceiverLinks tab) to adjust transmitter
or receiver settings while the channels are running.
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Auto Sweep Testing
Use the auto sweep feature to automatically sweep ranges for the best transceiver PMA settings. You can
store a history of the test runs and keep a record of the best PMA settings. You can use the best found settings
in your final design for improved signal integrity compared with the default settings.

Adaptive Equalization Control
Adaptive equalization (AEQ) automatically evaluates and selects the best combination of reconfiguration
equalizer settings for the receiver. AEQcontinuously evaluates and changes the settings for current conditions.
You can use AEQ for multiple, independently controlled receiver channels.

Enable this feature by selecting One-time adaptive for the Equalization control receiver setting.

Signal Eye Margin Testing
Some Altera devices include EyeQ circuitry that allows visualization of the horizontal and vertical eye margin
at the receiver. For supported devices, use signal eye tests to tune the PMA settings of your transceiver, which
results in the best eye margin and BER at high data rates. This GUI is disabled for unsupported devices.

The EyeQ graph displays a bathtub curve or eye diagram representing eye margin. The run list displays the
statistics of each EyeQ test. When PMA settings are suitable, the bathtub curve is wide, with sharp slopes
near the edges. The curve is up to 30 units wide. If the bathtub is narrow, then the signal quality is poor. The
wider the bathtub curve, the wider the eye. The smaller the bathtub curve, the smaller the eye. The eye
contour shows the estimated horizontal and vertical eye opening at the receiver.

You can right-click any of the test runs in the list, and then click Apply Settings to Device to quickly apply
that PMA setting to your device. You can also click Export, Import, or Create Report.

Figure 11-2: EyeQ Settings and Status Showing Results of Two Test Runs

Serial Bit Comparator Mode
Serial bit comparatormode allows you to runEyeQdiagnostic featureswith any PRBSpatterns or user-design
data, without disrupting the data path.
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To enable this mode you must enable the following debugging component options when configuring the
debugging system:

Table 11-2: Component Settings for Serial Bit Comparator Mode

Setting for Serial Bit ModeDebugging Component

Turn on Enable EyeQ block and Enable Bit Error Rate BlockTransceiver Reconfiguration
Controller

Turn on Enable Bypass interfaceData Pattern Generator

Serial bit comparator mode is less accurate than Data pattern checker mode for single bit error checking.
Do not use Serial bit comparator mode if you require an exact error rate. Use the Serial bit comparator
mode for checking a large window of error.

Serial bit comparator mode has the following hardware limitations:

• You can add only one BER counter per reconfiguration controller. You can monitor only one channel
at a time if the reconfiguration controller is shared by multiple channels.

• Use of the reconfiguration controller is limited while BER is running. For example, you cannot switch
logical channels, run decision feedback equalization one-time, run adaptive equalization one-time, or
recalibrate because it corrupts the error count.

• This method may double count the number of errors.
• The bit error counter is not read in real-time because it is read through the memory mapped interface.

Scripting Support
You can alternatively use Tcl commands to access Transceiver Toolkit functions, rather than using the GUI.
You can script various tasks, such as loading a project, creating design instances, linking device resources,
and identifying high-speed serial links. You can save your project setup in a Tcl script for use in subsequent
testing sessions. You can also build a custom test routine script.

After you set up and define links that describe the entire physical system, you can click Save Tcl Script to
save the setup for future use. To run the scripts, double-click script names in the System Explorer scripts
folder.

Related Information
Scripting API on page 11-26

Configuring Systems for Debug
To debug transceivers, you must first configure a system that includes the appropriate Altera IP core(s) that
supports each debugging operation. You can create such a system by either modifying an Altera design
example, or by integrating debugging components into your own design.

You can quickly parameterize the debugging components by clickingTools>MegaWizardPlug-InManager.
Refer to the following configuration for your debugging operation.
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Table 11-3: Transceiver Toolkit IP Core Configuration

Parameterization NotesDebugging FunctionsComponent

• If Enable 10G PCS is enabled, 10G PCS protocol
mode must be set to basic on the 10G PCS tab.

Supports all debugging
functions

TransceiverNative
PHY

• Set lanes, group size, serialization factor, data rate, and
input clock frequency to match your application.

• Turn on Avalon data interfaces.
• Disable 8B/10B.
• Set Word alignment mode to manual.
• Disable rate match FIFO.
• Disable byte ordering block.

Test all possible transceiver
parallel data widths

Custom PHY

• SetPhase compensationFIFOmode toEMBEDDED
above certain data rates and set to NONE for PMA
direct mode (Stratix IV designs only).

• Turn on Avalon data interfaces.
• Set serial loopback mode to enable serial loopback

controls in the toolkit.

Test at more than 8.5 Gbps in
GT devices or use of PMA
direct mode (such as when
using six channels in one
quad)

Low Latency PHY

• Select PRBS7, PRBS15, PRBS23, PRBS31, high
frequency, or low frequency patterns

Generates standard data test
patterns at Avalon-ST source
ports

Avalon-ST Data
Pattern Generator

• Specify a value for ST_DATA_W that matches the
FPGA-fabric interface width.

Validates incoming data
stream against test patterns
acceptedonAvalon streaming
sink ports

Avalon-ST Data
Pattern Checker

• Connect the reconfiguration controller to all PHYs
that you want controlled by the toolkit.

• Connect reconfig_from_xcvr to reconfig_
to_xcvr.

• Enable Analog controls.
• Enable EyeQ block (Stratix V devices only).
• Enable AEQ block (Stratix V devices only).
• Enable DFE block (Stratix V devices only).

Supports PMA control and
other transceiver settings

Reconfiguration
Controller

N/AAccepts encoded streams of
bytes with transaction data
and initiates Avalon-MM
transactions

JTAG to Avalon
Master Bridge

Related Information

• Adapting Altera Design Examples

• Integrating Debug Components In Your Design on page 11-8
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Adapting Altera Design Examples
Altera provides design examples to help you quickly test your own design. You can experiment with these
designs and modify them for your own application. Refer to the readme.txt of each design example for more
information. Download the Transceiver Toolkit design examples from the On-Chip Debugging Design
Examples page of the Altera website.

You can use the design examples as a starting point to work with a particular signal integrity development
board. The design examples provide the components to quickly test the functionality of the receiver and
transmitter channels in your design. You can easily change the transceiver settings in the design examples
to see how they affect your transceiver link performance. You can isolate and verify the high-speed serial
links without debugging other logic in your design. You can modify and customize the design examples to
match your intended transceiver design.

Once you have downloaded the design examples, open theQuartus II software and restore the design example
project archive. If you have access to the same development board with the same device as mentioned in the
readme.txt file of the example, you can directly program the device with the provided programming file in
that example. If you want to recompile the design, you must make your modifications to the configuration
in Qsys, regenerate in Qsys, and recompile the design in the Quartus II software to generate a new
programming file.

If you have the same board as mentioned in the readme.txt file, but a different device on your board, you
must choose the appropriate device and recompile the design. For example, some early development boards
are shipped with engineering sample devices.

You can make changes to the design examples so that you can use a different development board or different
device. You make pin assignment changes and then recompile the design. If you have a different board, you
must edit the necessary pin assignments and recompile the design examples.

Related Information

• On-Chip Debugging Design Examples

Modifying Design Examples
You can adapt an Altera design example to experiment with various configurations that match your own
design. For example, you can change data rate, number of lanes, PCS-PMA width, FPGA-fabric interface
width, or input reference clock frequency. Tomodify the design examples, youmodify the IP core parameters
and regenerate the system in Qsys. Next, you modify the top-level design file, and reassign device I/O pins
as necessary.

Before you begin

To modify a design example PHY block to match your design, follow these steps:

1. Determine the number of channels required by your design.
2. Open the <project name>.qpf for the design example in the Quartus II software.
3. Click Tools > Qsys.
4. On the System Contents tab, right-click the PHY block and click Edit. On the General tab, specify

options for the PHY block to match your design requirement for number of lanes, data rate, PCS-PMA
width, FPGA-fabric interface width, and input reference clock frequency.

5. Right-click the PHY block and click Edit. ClickAdditional Options and specify a multiple of the FPGA-
fabric interface data width for Avalon Data Symbol Size. The available values are 8 or 10. Click Finish.
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6. Delete any timing adapter from the design. The timing adaptors are not required.
7. Right-click data pattern generator and click Edit. Specify a value for ST_DATA_W that matches the

FPGA-fabric interface width.
8. Right-clickdata pattern checker and clickEdit. Specify a value for ST_DATA_W thatmatches the FPGA-

fabric interface width.
9. Right-click transceiver configuration controller and click Edit. Specify 2* number of lanes for the

number of reconfigurations interfaces. Click finish.
10. Add one data pattern generator and data pattern checker for each transmitter and receiver lane. From

the Component Library, instantiate the data pattern generator and data pattern checker components.
The components are under Debug and Performance under Peripherals.

11. Create connections for the data pattern generator and data pattern checker components. Right-click the
net name in the System Contents tab and specify the following connections.

ToFrom

Net NameBlock NameNet NameBlock Name

csr_clkdata_pattern_generatorclkclk_100

csr_clk_resetdata_pattern_generatorclk_resetclk_100

csr_slavedata_pattern_generatormastermaster_0

pattern_out_clkdata_pattern_generatortx_clk_out0xcvr_*_phy_0

pattern_outdata_pattern_generatortx_parallel_data0xcvr_*_phy_0

csr_clkdata_pattern_checkerclkclk_100

csr_clk_resetdata_pattern_checkerclk_resetclk_100

csr_slavedata_pattern_checkermastermaster_0

pattern_in_clkdata_pattern_checkerrx_clk_out0xcvr_*_phy_0

pattern_indata_pattern_checkerrx_parallel_data0xcvr_*_phy_0

12. Click System > Assign Base Addresses.
13. Connect the reset port of timing adapters to clk_reset of clk_100.
14. To implement the changes to the system, click Generate.
15. If you modify the number of lanes in the PHY, you must update the top-level file accordingly. The

following example shows Verilog HDL code for a two-channel design that declares input and output
ports in the top-level design. The example design includes the low latency PHY IP core. If you modify
the PHY parameters, you must modify the top-level design with the correct port names. Qsys displays
an example of the PHY in the design on the HDL example tab.

module low_latency_10g_1ch DUT ( 
 input  wire GXB_RXL11,
 input  wire GXB_RXL12,
 output wire GXB_TXL11,
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 output wire GXB_TX12
);
.....

low_latency_10g_1ch DUT (
 .....
 .xcvr_low_latency_phy_0_tx_serial_data_export ({GXB_TXL11,  
GXB_TXL12}),  
 .xcvr_low_latency_phy_0_rx_serial_data_export ({GXB_RXL11,   
GXB_TXL12}),  
 .....
 );

16. Click Assignments > Pin Planner and update pin assignments to match your board.
17. Edit the design’s Synopsys Design Constraints (.sdc) to reflect the reference clock change. Ignore the

reset warning messages.
18. Recompile the design.

Modifying Design Example Pin Assignments
Click Assignments > Pin Planner to modify pin assignments in your project to match development kit or
your own board.

Related Information

• Managing I/O Pins

Integrating Debug Components In Your Design
This section describes integrating debugging IP components into your own design. You can integrate
transceiver debugging components into your design, rather than modifying the Altera Debugging Design
Examples.

Configuring BER Tests
To integrate components with your design for BER testing, follow these steps.

1. To add and connect debugging components to your system, click Tools > Qsys.
2. Define and instantiate the following from the Qsys component library:

• Click Peripherals > Debug and Performance > Altera Avalon Data Pattern Generator. Turn on
Enable Bypass interface for connection to design logic.

• ClickPeripherals>Debug andPerformance>AlteraAvalonDataPatternChecker. Turn onEnable
Bypass interface for connection to design logic.

• Click Bidges > Memory-Mapped > JTAG to Avalon Master Bridge.

3. Make the following connections between components in your system:

ToFrom

Data Pattern Generator bypass portYour Design Logic

PHY input portData Pattern Generator

Altera Avalon Data Pattern GeneratorJTAG to Avalon Master Bridge

Debugging Transceiver LinksAltera Corporation

Send Feedback

QII53029
Modifying Design Example Pin Assignments11-8 2013.11.04

http://www.altera.com/literature/hb/qts/qts_qii52013.pdf
mailto:TechDocFeedback@altera.com?subject=Feedback%20on%20Debugging%20Transceiver%20Links%20(QII53029%202013.11.04)&body=We%20appreciate%20your%20feedback.%20In%20your%20comments,%20also%20specify%20the%20page%20number%20or%20paragraph.%20Thank%20you.


ToFrom

Altera Avalon Data Pattern CheckerJTAG to Avalon Master Bridge

PHY input portJTAG to Avalon Master Bridge

PHY output portData Pattern Checker

PHY input portTransceiver Reconfiguration Controller

4. To generate the system, click Generate > Generate.
5. To compile the design and generate configuration files, click Processing > Start Compilation.
6. Click Tools > Programmer and configure the target device with your debugging design.

You are now prepared to run BER tests.

Figure 11-3: BER Test Configuration
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Related Information
Running BER Tests on page 11-18

Configuring PRBS Signal Eye Tests
To integrate components with your design for testing PRBS signal eye, follow these steps.

1. To add and connect debugging components to your system, click Tools > Qsys.
2. Define and instantiate the following from the Qsys component library:
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• Click Peripherals > Debug and Performance > Altera Avalon Data Pattern Generator. Turn on
Enable Bypass interface for connection to design logic.

• ClickPeripherals>Debug andPerformance>AlteraAvalonDataPatternChecker. Turn onEnable
Bypass interface for connection to design logic.

• Click Bridges > Memory-Mapped > JTAG to Avalon Master Bridge.
• Click Interface Protocols > Transceiver PHY > Transceiver Reconfiguration Controller. Turn on

Enable EyeQ block to enable signal eye analysis.

3. Make the following connections between components in your system:

ToFrom

Data Pattern Generator bypass portYour Design Logic

PHY input portData Pattern Generator

Altera Avalon Data Pattern GeneratorJTAG to Avalon Master Bridge

Altera Avalon Data Pattern CheckerJTAG to Avalon Master Bridge

PHY output portData Pattern Checker

Transceiver Reconfiguration ControllerJTAG to Avalon Master Bridge

PHY input portJTAG to Avalon Master Bridge

PHY input portTransceiver Reconfiguration Controller

4. To generate the system, click Generate > Generate.
5. To compile the design and generate configuration files, click Processing > Start Compilation.
6. Click Tools > Programmer and configure the target device with your debugging design.

You are now prepared to run PRBS signal eye tests.

Figure 11-4: PRBS Signal Eye Test Configuration
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Related Information
Running PRBS Signal Eye Tests on page 11-19

Configuring Custom Traffic Signal Eye Tests
To integrate components with your design for testing custom traffic signal eye, follow these steps.

1. To add and connect debugging components to your system, click Tools > Qsys.
2. Define and instantiate the following from the Qsys component library:

• Click Bridges > Memory-Mapped > JTAG to Avalon Master Bridge.
• Click Interface Protocols > Transceiver PHY > Transceiver Reconfiguration Controller. Turn on

Enable EyeQ block to enable signal eye analysis. Turn on Enable Bit Error Rate Block to perform
BER testing.

3. Make the following connections between components in your system:

ToFrom

PHY input portYour design logic with custom traffic

Transceiver Reconfiguration ControllerJTAG to Avalon Master Bridge

PHY input portJTAG to Avalon Master Bridge

PHY input portTransceiver Reconfiguration Controller

4. To generate the system, click Generate > Generate.
5. To compile the design and generate configuration files, click Processing > Start Compilation.
6. Click Tools > Programmer and configure the target device with your debugging design.

You are now prepared to run custom traffic signal eye tests.

Figure 11-5: Custom Traffic Signal Eye Test Configuration
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Related Information
Running Custom Traffic Tests on page 11-19

Configuring Link Optimization Tests
To integrate components with your design for link optimization tests, follow these steps.

1. To add and connect debugging components to your system, click Tools > Qsys.
2. Define and instantiate the following from the Qsys component library:

• Click Peripherals > Debug and Performance > Altera Avalon Data Pattern Generator. Turn on
Enable Bypass interface for connection to design logic.

• ClickPeripherals>Debug andPerformance>AlteraAvalonDataPatternChecker. Turn onEnable
Bypass interface for connection to design logic.

• Click Bridges > Memory-Mapped > JTAG to Avalon Master Bridge.
• Click Interface Protocols > Transceiver PHY > Transceiver Reconfiguration Controller. Turn on

Enable EyeQ block, Enable Analog controls, Enable decision feedback equilizer (DFE) block, and
Enable adaptive equalization (AEQ) block to enable all types of link analysis.

3. Make the following connections between components in your system:

ToFrom

Data Pattern Generator bypass portYour Design Logic

PHY input portData Pattern Generator

Altera Avalon Data Pattern GeneratorJTAG to Avalon Master Bridge

Altera Avalon Data Pattern CheckerJTAG to Avalon Master Bridge

PHY output portData Pattern Checker

Transceiver Reconfiguration ControllerJTAG to Avalon Master Bridge

PHY input portJTAG to Avalon Master Bridge

PHY input portTransceiver Reconfiguration Controller

4. To generate the system, click Generate > Generate.
5. To compile the design and generate configuration files, click Processing > Start Compilation.
6. Click Tools > Programmer and configure the target device with your debugging design.

You are now prepared to run BER tests.
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Figure 11-6: Link Optimization Test Configuration
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Related Information
Running Link Optimization Tests on page 11-20

Configuring PMA Analog Setting Control
To integrate components for PMA analog setting control, follow these steps.

1. To add and connect debugging components to your system, click Tools > Qsys.
2. Define and instantiate the following from the Qsys component library:

• Click Bridges > Memory-Mapped > JTAG to Avalon Master Bridge.
• Click Interface Protocols > Transceiver PHY > Transceiver Reconfiguration Controller. Turn on

Enable Analog controls. You can optionally turn on Enable EyeQ block, Enable decision feedback
equilizer (DFE) block, and Enable adaptive equalization (AEQ) block to enable these types of link
analysis.

3. Make the following connections between components in your system:

ToFrom

Transceiver Reconfiguration ControllerJTAG to Avalon Master Bridge

PHY input portJTAG to Avalon Master Bridge

PHY input portTransceiver Reconfiguration Controller

4. To generate the system, click Generate > Generate.
5. To compile the design and generate configuration files, click Processing > Start Compilation.
6. Click Tools > Programmer and configure the target device with your debugging design.

You are now prepared to control PMA settings.
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Figure 11-7: PMA Analog Setting Control Configuration
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Related Information
Controlling PMA Analog Settings on page 11-20

Debugging Transceiver Links
The Transceiver Toolkit allows you to control and monitor the performance of high-speed serial links
running on your board in real-time. You can identify the transceiver links in your design, transmit a data
pattern across the transceiver link, and report the signal quality of the received data in terms of bit error
rate, bathtub curve, or EyeQ graph (for supported families).

The toolkit automatically identifies the transceiver links in your design, or you canmanually create transceiver
links. You can then run auto sweep to help you quickly identify the best physical media attachment (PMA)
settings for each link. You can directly control the transmitter/receiver channels to experiment with various
settings suggested by auto sweep. The EyeQ graph allows you to visualize the estimated horizontal and
vertical eye opening at the receiver.

The Transceiver Toolkit supports various transceiver link testing configurations. You can identify and test
the transceiver link between two Altera devices, or you can transmit a test pattern with a third-party device
and monitor the data on an Altera device receiver channel. If a third-party chip includes self-test capability,
then you can send the test pattern from the Altera device and monitor the signal integrity at the third-party
device receiver channel. If the third-party device supports reverse serial loopback, you can run the test entirely
within the Transceiver Toolkit.
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Before you can monitor transceiver channels, you must configure a system with debugging components,
and program the design into an FPGA. Once those steps are complete, use the following flow to test the
channels:

1. Load the design in Transceiver Toolkit
2. Link hardware resources
3. Verify hardware connections
4. Identify transceiver channels
5. Run link tests or control PMA analog settings
6. View results

Step 1: Load Your Design
The Transceiver Toolkit automatically loads the last compiled design upon opening. To load any design into
the toolkit, click File > Load Design and select the .sof programming file generated for your transceiver
design. Loading the .sof automatically links the design to the target hardware in the toolkit. The toolkit
automatically discovers links between transmitter and receiver of the same channel. The System Explorer
displays information about the loaded design.

Step 2: Link Hardware Resources
The toolkit automatically discovers connected hardware and designs. You can also manually link a design
to connected hardware resources in the System Explorer.

You can identify and test the transceiver link between two Altera devices, or you can transmit a test pattern
with a third-party device and monitor the data on an Altera device receiver channel. If a third-party device
includes self-test capability, you can send the test pattern from the Altera device and monitor the signal
integrity on the third-party receiver channel. If the third-party device supports reverse serial loopback, you
can run the test entirely within the Transceiver Toolkit.

If you are using more than one Altera board, you can set up a test with multiple devices linked to the same
design. This setup is useful when you want to perform a link test between a transmitter and receiver on two
separate devices. You can also load multiple Quartus II projects and make links between different systems.
You can perform tests on completely separate and unrelated systems in a single tool instance.

Prior to the Transceiver Toolkit version 11.1, you must manually load and link your design to
hardware. In version 11.1 and later, the Transceiver Toolkit automatically links any device
programmed with a project.

Note:
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Figure 11-8: One Channel Loopback Mode
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Figure 11-9: Four Channel Loopback Mode
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Linking One Design to One Device
To link one design to one device by one USB-Blaster download cable, follow these steps:

1. Load the design for your Quartus II project.
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2. Link each device to an appropriate design if the design has not auto-linked.
3. Create the link between channels on the device to test.

Linking Two Designs to Two Devices
To link two designs to two separate devices on the same board, connected by one USB-Blaster download
cable, follow these steps:

1. Load the design for all the Quartus II project files you might need.
2. Link each device to an appropriate design if the design has not auto-linked.
3. Open the project for the second device.
4. Link the second device on the JTAG chain to the second design (unless the design auto-links).
5. Create a link between the channels on the devices you want to test.

Linking Designs and Devices on Separate Boards
To link two designs to two separate devices on separate boards, connected to separateUSB-Blaster download
cables, follow these steps:

1. Load the design for all the Quartus II project files you might need.
2. Link each device to an appropriate design if the design has not auto-linked.
3. Create the link between channels on the device to test.
4. Link the device you connected to the second USB-Blaster download cable to the second design.
5. Create a link between the channels on the devices you want to test.

Linking One Design on Two Devices
To link the same design on two separate devices, follow these steps:

1. In the Transceiver Toolkit, open the .sof you are using on both devices.
2. Link the first device to this design instance.
3. Link the second device to the design.
4. Create a link between the channels on the devices you want to test.

Step 3: Verify Hardware Connections
After you load your design and link your hardware, verify that the channels are connected correctly and
looped back properly on the hardware. Use the toolkit to send data patterns and receive them correctly.
Verifying your link and correct channel before you perform Auto Sweep or EyeQ tests can save time in the
work flow.

After you have verified that the transmitter and receiver are communicating with each other, you can create
a link between the two transceivers so that you can perform Auto Sweep and EyeQ tests with this pair.

Step 4: Identify Transceiver Channels
The Transceiver Toolkit automatically displays recognized transmitter and receiver channels. The toolkit
identifies a channel automatically whenever a receiver and transmitter share a transceiver channel. You can
also manually identify the transmitter and receiver in a transceiver channel and create a link between the
two for testing.
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Figure 11-10: Identified Transceiver Links and Status

When you run link tests, channel color highlights indicate the test status:

Table 11-4: Transceiver Toolkit IP Core Configuration

Receiver ChannelTransmitter ChannelColor

Channel is closed or checker clock is not
running

Channel is closed or generator clock is not
running

Red

Checker is checking and data pattern is
locked

Generator is sending a patternGreen

Channel is open, checker clock is running,
and checker is not checking, or checker is
not checking

Channel is open, generator clock is running,
and generator is not sending a pattern, or
generator is not sending a pattern

Neutral

Checker is checking and data pattern is not
locked

N/AYellow

Step 5: Run Link Tests
Once you identify the transceiver channels for debugging, you can run various link tests in the toolkit.

Use the Transceiver Links tab to control link test. For example, use the Auto Sweep feature to sweep
transceiver settings to determine the parameters that support the best BER value. Open the Transmitter,
Receiver and Link Control panels to control the PMA settings and run tests.

Running BER Tests
You can run BER tests across your transceiver link. After programming the FPGA with your debugging
design, loading the design in the toolkit, and linking hardware, follow these steps to run BER tests:

1. Click Tools > System Console > Transceiver Toolkit.
2. Click theTransmitterChannels tab, select the generator youwant to control, and clickCreateTransmitter

Channel.
3. Click the Receiver Channels tab, select the checker you want to control, and click Create Receiver

Channel.
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4. Click the Transceiver Links tab, select the transmitter and receiver pair you want to control, and click
Create Transceiver Link.

5. Click Control Transceiver Link, and specify a PRBS Test pattern and Checker mode for the Data
pattern checker. If you select Bypass for the Test pattern, the toolkit bypasses the PRBS generator and
runs your design through the link. The bypass option is only available after you turn on Enable Bypass
interface in the Reconfiguration Controller component.

6. Experiment with Reconfiguration, Generator, or Checker settings.
7. Click Start to run the patternwith your settings. You can then click Inject Error to inject error bits,Reset

the counter, or Stop the test.

Related Information
Configuring BER Tests on page 11-8

Running PRBS Signal Eye Tests
You can run PRBS signal eye tests to visualize the estimated horizontal and vertical eye opening at the
receiver. After programming the FPGA with your debugging design, loading the design in the toolkit, and
linking hardware, follow these steps to run PRBS signal eye tests:

1. Click Tools > System Console > Transceiver Toolkit.
2. Click theTransmitterChannels tab, select the generator youwant to control, and clickCreateTransmitter

Channel.
3. Click the Receiver Channels tab, select the checker you want to control, and click Create Receiver

Channel.
4. Click theTransceiver Links tab, select the transmitter and receivers you want to control, and clickCreate

Transceiver Link .
5. Click Transceiver EyeQ, and select EyeQ as the Test mode. The EyeQ mode displays test results as a

bathtub curve or eye contour representing bit error and phase offset data.
6. Specify the PRBS Test pattern and the Checker mode. Use Serial bit comparator checker mode only

for checking a large window of error with custom traffic.
7. Specify Run length and EyeQ settings to control the test coverage and type of EyeQ results displayed,

respectively.
8. Click Start to run the pattern with your settings. EyeQ uses the current channel settings to start a phase

sweep of the channel. The phase sweep runs 32 iterations. As the run progresses, view the status under
EyeQ status. Use this diagram to compare PMA settings for the same channel and to choose the best
combination of PMA settings for a particular channel.

9. When the run completes the chart is displayed and the characteristics of each run are listed in the run
list. You can click Stop to halt the test, change the PMA settings, and re-start the test. ClickCreate Report
to export data to a table format for further viewing.

Related Information
Configuring PRBS Signal Eye Tests on page 11-9

Running Custom Traffic Tests
After programming the FPGA with your debugging design, loading the design in the toolkit, and linking
hardware, follow these steps to run custom traffic tests:

1. Click Tools > System Console > Transceiver Toolkit.
2. Click theReceiverChannels tab, select the associated reconfiguration controller, and clickCreateReceiver

Channel.
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3. Click the Receiver EyeQ, and select EyeQ as the Test mode. The EyeQ mode displays test results as a
bathtub curve or eye contour representing bit error and phase offset data.

4. Specify the PRBS Test pattern
5. For Checker mode, select Serial bit comparator. This option is only available after you turn on Enable

EyeQ block and Enable Bit Error Rate Block for the Reconfiguration Controller component.
6. Specify Run length and EyeQ settings to control the test coverage and type of EyeQ results displayed,

respectively.
7. Click Start to run the pattern with your settings. EyeQ uses the current channel settings to start a phase

sweep of the channel. The phase sweep runs 32 iterations. As the run progresses, view the status under
EyeQ status.

8. When the run completes the chart is displayed and the characteristics of each run are listed in the run
list. You can click Stop to halt the test, change the PMA settings, and re-start the test. ClickCreate Report
to export data to a table format for further viewing.

Related Information
Configuring Custom Traffic Signal Eye Tests on page 11-11

Running Link Optimization Tests
After programming the FPGA with your debugging design, loading the design in the toolkit, and linking
hardware, follow these steps to run link optimization tests:

1. Click Tools > System Console > Transceiver Toolkit.
2. Click the Transceiver Links tab, and select the channel you want to control.
3. Click Transceiver Autosweep. The Advanced tab appears with Auto sweep as Test mode.
4. Specify the PRBS Test pattern.
5. Specify Run length and experiment with the Transmitter settings, Reciever settings to control the test

coverage and PMA settings, respectively.
6. Click Start to run all combinations of tests meeting the PMA parameter limits.
7. When the run completes the chart is displayed and the characteristics of each run are listed in the run

list. You can click Stop to halt the test, change the PMA settings, and re-start the test. ClickCreate Report
to export data to a table format for further viewing.

8. To use decision feedback equalization (DFE) to determine the best tap settings, follow these steps:
a. Use the Auto sweep to find optimal PMA settings while leaving the DFE mode set to Off.
b. If BER = 0, use the best PMA settings achieved.
c. If BER > 0, use this PMA setting, and set the minimum and maximum values obtained from Auto

Sweep to match this setting. Set the maximum DFE range to limits for each of the three DFE settings.
d. Run Create Report to view the results and determine which DFE setting has the best BER. Use these

settings in conjunction with the PMA settings for the best results.

Related Information
Configuring Link Optimization Tests on page 11-12

Controlling PMA Analog Settings
You can directly control PMA analog settings to experiment with settings while the link is running. To
control PMA analog settings, follow these steps:

1. Click Tools > System Console > Transceiver Toolkit.
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2. Click the Transmitter Channels tab, define a transmitter without a generator, and click Create
Transmitter Channel.

3. Click theReceiverChannels tab, define a receiverwithout a generator, and clickCreateReceiverChannel.
4. Click theTransceiver Links tab, select the transmitter and receivers you want to control, and clickCreate

Transceiver Link .
5. ClickControlReceiverChannel,Control TransmitterChannel, orControl Transceiver Link to directly

control the PMA settings while running.

Related Information
Configuring PMA Analog Setting Control on page 11-13

Toolkit GUI Setting Reference
The following settings are available on the Receiver Channels, Transmitter Channels, and Transceiver
Links tabs for interaction with the transmitter or receiver channels or transceiver links in the Transceiver
Toolkit GUI.

Table 11-5: Transceiver Toolkit Control Panel Settings

Control PanelDescriptionSetting

Receiver

Transceiver Link

Ignores the vertical step settings for EyeQ. This feature
should be used when DFE is on and the EyeQ mode is
set to Bathtub curve.

1-D EyeQ mode

Transmitter

Receiver

Transceiver Link

Name you choose for the channel.Alias

Receiver

Transceiver Link

Reports the current and best tested bits, errors, bit error
rate, and case count for the current auto sweep test.

Auto sweep status

Receiver

Transceiver Link

Specifies errors divided by bits tested since the last reset
of the checker.

Bit error rate (BER)

Transmitter

Receiver

Transceiver Link

Logical address number of the transceiver channel.Channel address

Receiver

Transceiver Link

SpecifyData pattern checker or Serial bit comparator
for BER tests.

If you enable Serial bit comparator the Data Pattern
Generator sends the PRBS pattern, but the pattern is
checked by the serial bit comparator.

In Bypass mode, clicking Start begins counting on the
Serial bit comparator.

Checker mode
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Control PanelDescriptionSetting

Transmitter

Receiver

Transceiver Link

Data rate of the channel as read from the project file or
data rate as measured by the frequency detector.

To use the frequency detector, turn on Enable
FrequencyCounter in theData PatternChecker IP core
and/or Data Pattern Generator IP core, regenerate the
IP cores, and recompile the design.

The measured data rate depends on the Avalon
management clock frequency as read from the project
file.

Click the refresh button next to the measured Data
rate if you make changes to your settings and want to
sample the data rate again.

Data rate

Receiver

Transceiver Link

Circuitry that provides an equal boost to the incoming
signal across the frequency spectrum.

DC gain

Receiver

Transceiver Link

Decision feedback equalization (DFE) for improving
signal quality. One-timemodeDFE determines the best
tap settings and stops searching. There is also a one-time
adaptive mode button that automatically turns on one-
timemode and immediately populates converged values
into the manual settings lists. Adaptive mode DFE
automatically tries to find the best tap values.

DFE mode and tap
values 1-5

Receiver

Transceiver Link

Forces the transceiver channel to align to the word you
specify.

Enable word aligner

Receiver

Transceiver Link

Boosts the high-frequency gain of the incoming
signal, thereby compensating for the low-pass filter
effects of the physical medium. AEQ one-time
adaptation is supported inAuto Sweep.When usedwith
DFE, you need to use DFE triggered mode or DFE
continuous.

Equalization control

Receiver

Transceiver Link

Adaptive equalization (AEQ) automatically evaluates
and selects the best combination of equalizer settings.
The setting applies only to Stratix V devices. When
turned on, it automatically turns off Equalization
Control. The one-time selection determines the best
setting and stops searching. You can use AEQ for
multiple, independently controlled receiver channels.

Equalization mode
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Control PanelDescriptionSetting

Receiver

Transceiver Link

Turns on or off error rate limits. Start checking after
waits until the set number of bits are satisfied until it
starts looking at the bit error rate (BER) for the next two
checks.

Bit error rate achieves below sets upper bit error rate
limits. If the error rate is better than the set error rate,
the test ends.

Bit error rate exceeds Sets lower bit error rate limits. If
the error rate is worse than the set error rate, the test
ends.

Error rate limit

Transmitter

Receiver

Transceiver Link

Allows you to specify Eye contour or Bathtub curve as
the type of EyeQ graph generated by the test.

EyeQ mode

Receiver

Transceiver Link

Sets the phase step for sampling the data from an offset
of the CDR (clock data recovery) data path; set to Off
to use the regular clock data recovery (CDR) data path.

EyeQ phase step

Transmitter

Receiver

Transceiver Link

Displays a graphical representation of signal integrity
as an eye contour or bathtub curve plot.

EyeQ status

Receiver

Transceiver Link

Sets the voltage threshold of the sampler to report the
height of the eye. Negative numbers are allowed for
vertical steps to capture asymmetric eye.

EyeQ vertical step

Transmitter

Receiver

Transceiver Link

Specify the number of horizontal steps to increment
when performing a sweep. Increasing the value increases
the speed of the test but at a lower resolution. This
option only applies to eye contour.

Horizontal phase
step interval

Receiver

Transceiver Link

Right-click in the Advanced panel to use the span
capabilities of Auto Sweep to automatically increase the
span of tests by one unit down for the minimum and
one unit up for the maximum, for the selected set of
controls. You can span either PMA Analog controls
(non-DFE controls), or the DFE controls. You can
quickly set up a test to check if any PMA setting
combinations near your current best could yield better
results.

Increase test range

Transmitter

Transceiver Link

Flips one bit to the output of the data pattern generator
to introduce an artificial error.

Inject Error
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Control PanelDescriptionSetting

Receiver

Transceiver Link

Sets the maximum number of tested bits for each test
iteration.

Maximum tested
bits

Receiver

Transceiver Link

Specifies the number of bits tested since the last reset of
the checker.

Number of bits
tested

Receiver

Transceiver Link

Specifies the number of error bits encountered since the
last reset of the checker.

Number of error bits

Transmitter

Transceiver Link

The number of clock cycles towhich the preambleword
is sent before the test pattern begins.

Numberof preamble
beats

Transmitter

Receiver

Transceiver Link

Channel reference clock frequency as read from the
project file or measured reference clock frequency as
calculated from the measured data rate.

PLL refclk freq

Receiver

Transceiver Link

Right-click in theAdvanced panel to load current values
on the device as a starting point, or initially load the best
settings determined through auto sweep. The Quartus
II software automatically applies the values you specify
in the drop-down lists for the Transmitter settings and
Receiver settings.

Populate with

Transmitter

Transceiver Link

Word to send out if the preamble mode is used.Preamble word

Transmitter

Transceiver Link

The programmable pre-emphasis module in each
transmit buffer boosts high frequencies in the transmit
data signal, whichmay be attenuated in the transmission
media. Using pre-emphasis can maximize the data eye
opening at the far-end receiver.

Pre-emphasis

Receiver

Transceiver Link

Specifies the name of the selected receiver channel.Receiver channel

Receiver

Transceiver Link

Resets the current test.Reset
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Control PanelDescriptionSetting

Receiver

Transceiver Link

Displays invalid combination of settings in red in each
list under Transmitter settings and Receiver settings,
based on previous settings. If selected, the settings
remain in red to indicate the currently selected
combination is invalid. This feature helps you to avoid
manually testing invalid settings that cannot be compiled
into your design. Also, this feature helps to prevent you
from setting the device into an invalid mode for
extended periods of time and potentially damaging the
circuits.

Rules Based
Configuration
(RBC) validity
checking

Transmitter

Receiver

Transceiver Link

Sets coverage parameters for test runs.Run length

Transmitter

Receiver

Transceiver Link

Lists the statistics of each EyeQ test run. The run table
is sortable. You can right-click any of the tests in the
table and then clickApply Settings toDevice to quickly
apply the chosen PMA settings to your device. You can
click Import to load reports from previously generated
EyeQ runs into the run table. You can click Export to
export single or multiple runs from the run table to a
report.

Run table

Receiver

Transceiver Link

Shows the receiver in lock-to-reference (LTR) mode.
When in auto-mode, if data cannot be locked, this signal
alternates in LTD mode if the CDR is locked to data.

RX CDR PLL status

Receiver

Transceiver Link

Shows the receiver in lock-to-data (LTD) mode. When
in auto-mode, if data cannot be locked, the signal stays
high when locked to data and never toggles.

RX CDR data status

Transmitter

Receiver

Transceiver Link

Inserts a serial loopback before the buffers, allowing you
to form a link on a transmitter and receiver pair on the
same physical channel of the device.

Serial loopback
enabled

Transmitter

Receiver

Transceiver Link

Starts the pattern generator or checker on the channel
to verify incoming data.

Start

Transmitter

Receiver

Transceiver Link

Stops generating patterns and testing the channel.Stop
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Control PanelDescriptionSetting

Transmitter

Receiver

Transceiver Link

Finds the contour edge of the bit error rate that you
select. This option only applies to eye contour mode.

Target bit error rate

Receiver

Transceiver Link

Allows you to specify the Auto sweep, EyeQ, or Auto
sweep and EyeQ test mode.

Test mode

Transmitter

Receiver

Transceiver Link

Test pattern sent by the transmitter channel. Options
include PRBS7, PRBS15, PRBS23, PRBS31,
LowFrequency, andHighFrequency andBypassmode.
The Data Pattern Checker self-aligns both high and low
frequency patterns. Use Bypass mode to send user-
design data.

Test pattern

Receiver

Transceiver Link

Specifies the time limit unit and value to have a
maximum bounds time limit for each test iteration

Time limit

Transmitter

Transceiver Link

Specifies the name of the selected transmitter channel.Transmitter channel

Transmitter

Transceiver Link

Provides status of whether the transmitter channel PLL
is locked to the reference clock.

TX/CMUPLL status

Transmitter

Transceiver Link

If turned on, sends the preamble word before starting
of the test pattern. If turned off, starts sending the test
pattern immediately.

Use preamble upon
start

Transmitter

Receiver

Transceiver Link

Specify the number of vertical steps to increment when
performing a sweep. Increasing the value increases the
speed of the test but at a lower resolution. This option
only applies to eye contour.

Vertical phase step
interval

Transmitter

Transceiver Link

Programmable transmitter differential output voltage.VOD control

Scripting API
You can alternatively use Tcl commands to access Transceiver Toolkit functions, rather than using the GUI.
You can script various tasks, such as loading a project, creating design instances, linking device resources,
and identifying high-speed serial links. You can save your project setup in a Tcl script for use in subsequent
testing sessions. You can also build a custom test routine script.

After you set up and define links that describe the entire physical system, you can click Save Tcl Script to
save the setup for future use. To run the scripts, double-click script names in the System Explorer scripts
folder.
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View a list of the available Tcl commands in the Tcl Console window. Select Tcl commands in the list to
view descriptions, including example usage.

To view Tcl command descriptions from the Tcl Console window:

1. Type help help. The Console displays all Transceiver Toolkit Tcl commands.
2. Type help <command name>. The Console displays the command description.

The following Tcl command example uses the following commands to locate and open an instance of the
master service.

• set—Tcl command that sets the value of a variable.
• m_path—name of a variable.
• lindex—Tcl command that retrieves an element from a list.
• get_service_paths—returns a list of service instances by type.
• master—service type that accesses memory-mapped slaves.
• n—number of the master service.
• open_service—initiates a service instance.

set m_path [lindex [get_service_paths master] n]
open_service master $m_path

Transceiver Toolkit Commands
The following tables list the available Transceiver Toolkit scripting commands.

Table 11-6: Transceiver Toolkit Channel_rx Commands

FunctionArgumentsCommand

Returns a list of the current
checker data. The results are in the
order of number of bits, number
of errors, and bit error rate.

<service-path>transceiver_channel_rx_
get_data

Gets the DC gain value on the
receiver channel.

<service-path>transceiver_channel_rx_
get_dcgain

Gets the current tap value of the
specified channel at the specified
tap position.

<service-path> <tap position>transceiver_channel_rx_
get_dfe_tap_value

Gets the equalization control value
on the receiver channel.

<service-path>transceiver_channel_rx_
get_eqctrl

Returns the current data checker
pattern by name.

<service-path>transceiver_channel_rx_
get_pattern

Gets whether this channel has the
DFE feature available.

<service-path>transceiver_channel_rx_
has_dfe

Gets whether the EyeQ feature is
available for the specified channel.

<service-path>transceiver_channel_rx_
has_eyeq
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FunctionArgumentsCommand

Returns non-zero if the checker is
running.

<service-path>transceiver_channel_rx_
is_checking

Gets whether the DFE feature is
enabled on the specified channel.

<service-path>transceiver_channel_rx_
is_dfe_enabled

Returns non-zero if the checker is
locked onto the incoming data.

<service-path>transceiver_channel_rx_
is_locked

Resets the bit and error counters
inside the checker.

<service-path>transceiver_channel_rx_
reset_counters

Resets the specified channel.<service-path>transceiver_channel_rx_
reset

Sets the DC gain value on the
receiver channel.

<service-path> <value>transceiver_channel_rx_
set_dcgain

Enables or disables the DFE
feature on the specified channel.

<service-path> <disable(0)/enable(1)
>

transceiver_channel_rx_
set_dfe_enabled

Sets the current tap value of the
specified channel at the specified
tap position to the specified value.

<service-path> <tap position> <tap
value>

transceiver_channel_rx_
set_dfe_tap_value

Gets themode ofDFE adaptation.
0=off, 1=adaptive, 2= one-time
adaptive

<service-path>transceiver_channel_rx_
get_dfe_adaptive

Sets the mode of DFE adaptation.
0=off, 1=adaptive, 2= one-time
adaptive

<service-path>transceiver_channel_rx_
set_dfe_adaptive

Sets the equalization control value
on the receiver channel.

<service-path> <value>transceiver_channel_rx_
set_eqctrl

Starts the checker.<service-path>transceiver_channel_rx_
start_checking

Stops the checker.<service-path>transceiver_channel_rx_
stop_checking

Gets the current phase step of the
specified channel.

<service-path>transceiver_channel_rx_
get_eyeq_phase_step

Sets the expected pattern to the
one specified by the pattern name.

<service-path> <pattern-name>transceiver_channel_rx_
set_pattern

Gets whether the EyeQ feature is
enabled on the specified channel.

<service-path>transceiver_channel_rx_
is_eyeq_enabled
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FunctionArgumentsCommand

Enables or disables the EyeQ
feature on the specified channel.

<service-path> <disable(0)/enable(1)
>

transceiver_channel_rx_
set_eyeq_enabled

Sets the phase step of the specified
channel.

<service-path> <phase step>transceiver_channel_rx_
set_eyeq_phase_step

Enables or disables the word
aligner of the specified channel.

<service-path> <disable(0)/enable(1)
>

transceiver_channel_rx_
set_word_aligner_
enabled

Gets whether the word aligner
feature is enabled on the specified
channel.

<service-path> <disable(0)/enable(1)
>

transceiver_channel_rx_
is_word_aligner_enabled

Returns non-zero if the checker is
locked onto the incoming signal.

<service-path>transceiver_channel_rx_
is_locked

Returns 1 if transceiver is in lock
to data (LTD)mode. Otherwise0.

<service-path>transceiver_channel_rx_
is_rx_locked_to_data

Returns 1 if transceiver is in lock
to reference (LTR) mode.
Otherwise 0.

<service-path>transceiver_channel_rx_
is_rx_locked_to_ref

Detects whether the eye viewer
pointed to by <service-path>
supports 1D-EyeQ mode.

<service-path>transceiver_channel_rx_
has_eyeq_1d

Enables or disables 1D-EyeQ
mode.

<service-path> <disable(0)/enable(1)
>

transceiver_channel_rx_
set_1deye_mode

Returns the current on or off
status of 1D-EyeQ mode.

<service-path>transceiver_channel_rx_
get_1deye_mode

Table 11-7: Transceiver Toolkit Channel _tx Commands

FunctionArgumentsCommand

Disables the preamblemode at the
beginning of generation.

<service-path>transceiver_channel_tx_
disable_preamble

Enables the preamble mode at the
beginning of generation.

<service-path>transceiver_channel_tx_
enable_preamble

Returns the currently set number
of beats to send out the preamble
word.

<service-path>transceiver_channel_tx_
get_number_of_preamble_
beats

Returns the currently set pattern.<service-path>transceiver_channel_tx_
get_pattern
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FunctionArgumentsCommand

Returns the currently set preamble
word.

<service-path>transceiver_channel_tx_
get_preamble_word

Gets the pre-emphasis pre-tap
value on the transmitter channel.

<service-path>transceiver_channel_tx_
get_preemph0t

Gets the pre-emphasis first post-
tap value on the transmitter
channel.

<service-path>transceiver_channel_tx_
get_preemph1t

Gets the pre-emphasis second
post-tap value on the transmitter
channel.

<service-path>transceiver_channel_tx_
get_preemph2t

Gets the VOD control value on the
transmitter channel.

<service-path>transceiver_channel_tx_
get_vodctrl

Injects a 1-bit error into the
generator's output.

<service-path>transceiver_channel_tx_
inject_error

Returns non-zero if the generator
is running.

<service-path>transceiver_channel_tx_
is_generating

Returns non-zero if preamble
mode is enabled.

<service-path>transceiver_channel_tx_
is_preamble_enabled

Sets the number of beats to send
out the preamble word.

<service-path><number-of-preamble-
beats>

transceiver_channel_tx_
set_number_of_preamble_
beats

Sets the output pattern to the one
specified by the pattern name.

<service-path> <pattern-name>transceiver_channel_tx_
set_pattern

Sets the preamble word to be sent
out.

<service-path> <preamble-word>transceiver_channel_tx_
set_preamble_word

Sets the pre-emphasis pre-tap
value on the transmitter channel.

<service-path>

<preemph0t value>

transceiver_channel_tx_
set_preemph0t

Sets the pre-emphasis first post-
tap value on the transmitter
channel.

<service-path>

<preemph1t value>

transceiver_channel_tx_
set_preemph1t

Sets the pre-emphasis second
post-tap value on the transmitter
channel.

<service-path>

<preemph2t value>

transceiver_channel_tx_
set_preemph2t

Sets the VOD control value on the
transmitter channel.

<service-path>

< vodctrl value>

transceiver_channel_tx_
set_vodctrl
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FunctionArgumentsCommand

Starts the generator.<service-path>transceiver_channel_tx_
start_generation

Stops the generator.<service-path>transceiver_channel_tx_
stop_generation

Table 11-8: Transceiver Toolkit Transceiver Toolkit Debug_Link Commands

FunctionArgumentsCommand

Gets the currently set pattern the
link uses to run the test.

<service-path>transceiver_debug_link_
get_pattern

Returns non-zero if the test is
running on the link.

<service-path>transceiver_debug_link_
is_running

Sets the pattern the link uses to
run the test.

<service-path> <data pattern>transceiver_debug_link_
set_pattern

Starts running a test with the
currently selected test pattern.

<service-path>transceiver_debug_link_
start_running

Stops running the test.<service-path>transceiver_debug_link_
stop_running

Table 11-9: Transceiver Toolkit Reconfig_Analog Commands

FunctionArgumentsCommand

Gets the transceiver logical
channel address currently set.

<service-path>transceiver_reconfig_
analog_get_logical_
channel_address

Gets the DC gain value on the
receiver channel specified by the
current logical channel address.

<service-path>transceiver_reconfig_
analog_get_rx_dcgain

Gets the equalization control value
on the receiver channel specified
by the current logical channel
address.

<service-path>transceiver_reconfig_
analog_get_rx_eqctrl

Gets the pre-emphasis pre-tap
value on the transmitter channel
specified by the current logical
channel address.

<service-path>transceiver_reconfig_
analog_get_tx_preemph0t
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FunctionArgumentsCommand

Gets the pre-emphasis first post-
tap value on the transmitter
channel specified by the current
logical channel address.

<service-path>transceiver_reconfig_
analog_get_tx_preemph1t

Gets the pre-emphasis second
post-tap value on the transmitter
channel specified by the current
logical channel address.

<service-path>transceiver_reconfig_
analog_get_tx_preemph2t

Gets the VOD control value on the
transmitter channel specified by
the current logical channel
address.

<service-path>transceiver_reconfig_
analog_get_tx_vodctrl

Sets the transceiver logical channel
address.

<service-path>

<logical channel address>

transceiver_reconfig_
analog_set_logical_
channel_address

Sets the DC gain value on the
receiver channel specified by the
current logical channel address

<service-path>

< dc_gain value>

transceiver_reconfig_
analog_set_rx_dcgain

Sets the equalization control value
on the receiver channel specified
by the current logical channel
address.

<service-path>

< eqctrl value>

transceiver_reconfig_
analog_set_rx_eqctrl

Sets the pre-emphasis pre-tap
value on the transmitter channel
specified by the current logical
channel address.

<service-path>

<preemph0t value>

transceiver_reconfig_
analog_set_tx_preemph0t

Sets the pre-emphasis first post-
tap value on the transmitter
channel specified by the current
logical channel address.

<service-path>

<preemph1t value>

transceiver_reconfig_
analog_set_tx_preemph1t

Sets the pre-emphasis second
post-tap value on the transmitter
channel specified by the current
logical channel address.

<service-path>

<preemph2t value>

transceiver_reconfig_
analog_set_tx_preemph2t

Sets the VOD control value on the
transmitter channel specified by
the current logical channel
address.

<service-path>

< vodctrl value>

transceiver_reconfig_
analog_set_tx_vodctrl

.
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Table 11-10: Transceiver Toolkit Decision Feedback Equalization (DFE) Commands

FunctionArgumentsCommand

Gets the logical channel address
that other alt_xcvr_
reconfig_dfe commands use
to apply.

<service-path>alt_xcvr_reconfig_dfe_
get_logical_channel_
address

Gets whether the DFE feature is
enabled on the previously
specified channel.

<service-path>alt_xcvr_reconfig_dfe_
is_enabled

Enables or disables the DFE
feature on the previously specified
channel.

<service-path> <disable(0)/enable(1)
>

alt_xcvr_reconfig_dfe_
set_enabled

Sets the logical channel address
that other alt_xcvr_
reconfig_eye_viewer
commands use.

<service-path> <logical channel
address>

alt_xcvr_reconfig_dfe_
set_logical_channel_
address

Sets the tap value at the previously
specified channel at specified tap
position and value.

<service-path> <tap position> <tap
value>

alt_xcvr_reconfig_dfe_
set_tap_value

Table 11-11: Transceiver Toolkit Eye Monitor Commands

FunctionArgumentsCommand

Gets whether the word aligner
feature is enabled on the
previously specified channel.

<service-path> <disable(0)/enable(1)
>

alt_xcvr_custom_is_
word_aligner_enabled

Enables or disables the word
aligner of the previously specified
channel.

<service-path> <disable(0)/enable(1)
>

alt_xcvr_custom_set_
word_aligner_enabled

Returnswhether the receiverCDR
is locked to data.

<service-path>alt_xcvr_custom_is_rx_
locked_to_data

Returnswhether the receiverCDR
PLL is locked to the reference
clock.

<service-path>alt_xcvr_custom_is_rx_
locked_to_ref

Returns whether the serial
loopback mode of the previously
specified channel is enabled.

<service-path>alt_xcvr_custom_is_
serial_loopback_enabled
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FunctionArgumentsCommand

Enables or disables the serial
loopback mode of the previously
specified channel.

<service-path> <disable(0)/enable(1)
>

alt_xcvr_custom_set_
serial_loopback_enabled

Returns whether the transmitter
PLL is locked to the reference
clock.

<service-path>alt_xcvr_custom_is_tx_
pll_locked

Gets the logical channel address
on which other alt_
reconfig_eye_viewer
commands will use to apply.

<service-path>alt_xcvr_reconfig_eye_
viewer_get_logical_
channel_address

Gets the current phase step of the
previously specified channel.

<service-path>alt_xcvr_reconfig_eye_
viewer_get_phase_step

Gets whether the EyeQ feature is
enabled on the previously
specified channel.

<service-path>alt_xcvr_reconfig_eye_
viewer_is_enabled

Enables or disables the EyeQ
feature on the previously specified
channel.

Setting a value of 2 enables both
EyeQ and the Serial Bit
Comparator.

<service-path> <disable(0)/enable(1)
>

alt_xcvr_reconfig_eye_
viewer_set_enabled

Sets the logical channel address on
which other alt_reconfig_
eye_viewer commandswill use
to apply.

<service-path> <logical channel
address>

alt_xcvr_reconfig_eye_
viewer_set_logical_
channel_address

Sets the phase step of the
previously specified channel.

<service-path> <phase step>alt_xcvr_reconfig_eye_
viewer_set_phase_step

Detects whether the eye viewer
pointed to by <service-path>
supports the Serial Bit
Comparator.

<service-path>alt_xcvr_reconfig_eye_
viewer_has_ber_checker

Detects whether the Serial Bit
Comparator is enabled.

<service-path>alt_xcvr_reconfig_eye_
viewer_ber_checker_is_
enabled

Starts the Serial Bit Comparator
counters.

<service-path>alt_xcvr_reconfig_eye_
viewer_ber_checker_
start
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FunctionArgumentsCommand

Stops the Serial Bit Comparator
counters.

<service-path>alt_xcvr_reconfig_eye_
viewer_ber_checker_stop

Resets the Serial Bit Comparator
counters.

<service-path>alt_xcvr_reconfig_eye_
viewer_ber_checker_
reset_counters

Gets whether the Serial Bit
Comparator counters are
currently running or not.

<service-path>alt_xcvr_reconfig_eye_
viewer_ber_checker_is_
running

Gets the current total bit, error bit,
and exception counts for the Serial
Bit Comparator.

<service-path>alt_xcvr_reconfig_eye_
viewer_ber_checker_get_
data

Detects whether the eye viewer
pointed to by <service-path>
supports 1D-EyeQ mode.

<service-path>alt_xcvr_reconfig_eye_
viewer_has_1deye

Enables or disables 1D-EyeQ
mode.

<service-path>

<disable(0)/enable(1)

alt_xcvr_reconfig_eye_
viewer_set_1deye_mode

Gets the enable or disabled state
of 1D-EyeQ mode.

<service-path>alt_xcvr_reconfig_eye_
viewer_get_1deye_mode

Table 11-12: Channel Type Commands

FunctionArgumentsCommand

Reports the detected type (GX/
GT) of channel <logical-channel-
num > for the reconfiguration
block located at <service-path>.

<service-path>

<logical-channel- num >

get_channel_type

Overrides the detected channel
type of channel <logical-channel-
num > for the reconfiguration
block located at <service-path> to
the type specified (0:GX, 1:GT).

<service-path>

<logical-channel- num >

<channel-type>

set_channel_type
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Table 11-13: Loopback Commands

FunctionArgumentsCommand

Returns the value of a setting or
result on the loopback channel.
Available results include:

• Status—running or stopped.
• Bytes—number of bytes sent

through the loopback channel.
• Errors—number of errors

reported by the loopback
channel.

• Seconds—number of seconds
since the loopback channelwas
started.

<service-path>loopback_get

Sets the value of a setting control-
ling the loopback channel. Some
settings are only supported by
particular channel types. Available
settings include:

• Timer—number of seconds for
the test run.

• Size—size of the test data.
• Mode—mode of the test.

<service-path>loopback_set

Starts sending data through the
loopback channel.

<service-path>loopback_start

Stops sending data through the
loopback channel.

<service-path>loopback_stop

Data Pattern Generator Commands
You can use Data Pattern Generator commands to control data patterns for debugging transceiver channels.
You must instantiate the Data Pattern Generator component to support these commands.

Table 11-14: Data Pattern Generator Commands

FunctionArgumentsCommand

Starts the data pattern generator.<service-path>data_pattern_generator_
start

Stops the data pattern generator.<service-path>data_pattern_generator_
stop
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FunctionArgumentsCommand

Returns non-zero if the generator
is running.

<service-path>data_pattern_generator_
is_generating

Injects a 1-bit error into the
generator output.

<service-path>data_pattern_generator_
inject_error

Sets the output pattern specified
by the <pattern-name>. In all, 6
patterns are available, 4 are
pseudo-randombinary sequences
(PRBS), 1 is high frequency and 1
is low frequency.

The PRBS7, PRBS15, PRBS23,
PRBS31, HF (outputs high
frequency, constant pattern of
alternating 0s and 1s), and LF
(outputs low frequency, constant
pattern of 10b’1111100000 for 10-
bit symbols and 8b’11110000 for
8-bit symbols) pattern names are
defined.

PRBS files are clear text and you
can modify the PRBS files.

<service-path> <pattern-name>data_pattern_generator_
set_pattern

Returns currently selected output
pattern.

<service-path>data_pattern_generator_
get_pattern

Returns a list of available data
patterns by name.

<service-path>data_pattern_generator_
get_available_patterns

Enables the preamble mode at the
beginning of generation.

<service-path>data_pattern_generator_
enable_preamble

Disables the preamblemode at the
beginning of generation.

<service-path>data_pattern_generator_
disable_preamble

Returns a non-zero value if
preamble mode is enabled.

<service-path>data_pattern_generator_
is_preamble_enabled

Sets the preamble word (could be
32-bit or 40-bit).

<service-path> <preamble-word>data_pattern_generator_
set_preamble_word

Gets the preamble word.<service-path>data_pattern_generator_
get_preamble_word

Sets the number of beats to send
out in the preamble word.

<service-path> <number-of-
preamble- beats>

data_pattern_generator_
set_preamble_beats
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FunctionArgumentsCommand

Returns the currently set number
of beats to send out in the
preamble word.

<service-path>data_pattern_generator_
get_preamble_beats

Sets themax cycle count and starts
the frequency counter.

<service-path>

<max-cycles>

data_pattern_generator_
fcnter_start

Queries the data pattern generator
for current status. Returns a
bitmap indicating the status, with
bits defined as follows: [0]-
enabled, [1]-bypass enabled, [2]-
avalon, [3]-sink ready, [4]-source
valid, and [5]-frequency counter
enabled.

<service-path>data_pattern_generator_
check_status

Reports the current measured
clock ratio, stopping the counting
first depending on <force-stop>.

<service-path>

<force-stop>

data_pattern_generator_
fcnter_report

Data Pattern Checker Commands
You can use Data Pattern Checker commands to verify your generated data patterns. You must instantiate
the Data Pattern Checker component to support these commands.

Table 11-15: Data Pattern Checker Commands

FunctionArgumentsCommand

Starts the data pattern checker.<service-path>data_pattern_checker_
start

Stops the data pattern checker.<service-path>data_pattern_checker_
stop

Returns a non-zero value if the
checker is running.

<service-path>data_pattern_checker_
is_checking

Returns non-zero if the checker is
locked onto the incoming data.

<service-path>data_pattern_checker_
is_locked

Sets the expected pattern to the
one specified by the <pattern-
name>.

<service-path> <pattern-name>data_pattern_checker_
set_pattern

Returns the currently selected
expected pattern by name.

<service-path>data_pattern_checker_
get_pattern
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FunctionArgumentsCommand

Returns a list of available data
patterns by name.

<service-path>data_pattern_checker_
get_available_patterns

Returns a list of the current
checker data. The results are in the
following order: number of bits,
number of errors, and bit error
rate.

<service-path>data_pattern_checker_
get_data

Resets the bit and error counters
inside the checker.

<service-path>data_pattern_checker_
reset_counters

Sets themax cycle count and starts
the frequency counter.

<service-path>

<max-cycles>

data_pattern_checker_
fcnter_start

Queries the data pattern checker
for current status. Returns a
bitmap indicating status, with bits
defined as follows: [0]-enabled,
[1]-locked, [2]-bypass enabled,
[3]-avalon, [4]-sink ready, [5]-
source valid, and [6]-frequency
counter enabled.

<service-path>data_pattern_checker_
check_status

Reports the current measured
clock ratio, stopping the counting
first depending on <force-stop>.

<service-path>

<force-stop>

data_patte rn_checker_
fcnter_report

Revision History
The following table shows the revision history for this chapter.

Table 11-16: Document Revision History

ChangesVersionDate

• Reorganization and conversion to DITA.13.1.0November,
2013

• Added Conduit Mode Support, Serial Bit Comparator, Required Files and Tcl
command tables.

13.0.0May, 2013

• Minor editorial updates. AddedTcl help information and removedTcl command
tables. Added 28-Gbps Transceiver support section.

12.1.0November,
2012

• General reorganization and revised steps in modifying Altera example designs.12.0.1August, 2012

• Maintenance release for update of Transceiver Toolkit features.12.0.0June, 2012
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ChangesVersionDate

• Maintenance release for update of Transceiver Toolkit features.11.1.0November,
2011

• Added new Tcl scenario.11.0.0May, 2011

• Changed to new document template. Added new 10.1 release features.10.1.0December,
2010

• Corrected links.10.0.1August, 2010

• Initial release.10.0.0July 2010
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